summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58624556..fc854ad7 100755
--- a/configure.ac
+++ b/configure.ac
@@ -216,6 +216,11 @@ case "${enable_vtysh}" in
AC_MSG_ERROR([readline is too old to have readline/history.h, please update to the latest readline library.])
fi
;;
+ AC_CHECK_LIB(readline, rl_completion_matches)
+ if test $ac_cv_lib_readline_rl_completion_matches = no; then
+ AC_DEFINE(rl_completion_matches,completion_matches,Old readline)
+ fi
+ ;;
"no" ) VTYSH="";;
* ) ;;
esac