summaryrefslogtreecommitdiff
path: root/babeld/Makefile.am
diff options
context:
space:
mode:
authorAvneesh Sachdev <avneesh@opensourcerouting.org>2012-04-09 00:25:15 -0700
committerAvneesh Sachdev <avneesh@opensourcerouting.org>2012-04-09 00:25:15 -0700
commit3cf6c2b4e43f44a977d218c96c26250654ae333e (patch)
treee017cde2015fbf3ef6c250327428d7c6152aa8f7 /babeld/Makefile.am
parent01d7ff0a2166a422c56bd26f04fc22832a9e690b (diff)
parente96b312150d8e376c1ef463793d1929eca3618d5 (diff)
Merge branch 'quagga' into google-bgp-multipath
Conflicts: bgpd/bgp_route.c
Diffstat (limited to 'babeld/Makefile.am')
-rw-r--r--babeld/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/babeld/Makefile.am b/babeld/Makefile.am
new file mode 100644
index 00000000..468b5a5f
--- /dev/null
+++ b/babeld/Makefile.am
@@ -0,0 +1,29 @@
+## Process this file with automake to produce Makefile.in.
+
+INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib @SNMP_INCLUDES@
+DEFS = @DEFS@ -DSYSCONFDIR=\"$(sysconfdir)/\"
+INSTALL_SDATA=@INSTALL@ -m 600
+
+AM_CFLAGS = $(PICFLAGS)
+AM_LDFLAGS = $(PILDFLAGS)
+
+noinst_LIBRARIES = libbabel.a
+sbin_PROGRAMS = babeld
+
+libbabel_a_SOURCES = \
+ babel_zebra.c net.c kernel.c util.c source.c neighbour.c \
+ route.c xroute.c message.c resend.c babel_interface.c babeld.c \
+ babel_filter.c
+
+noinst_HEADERS = \
+ babel_zebra.h net.h kernel.h util.h source.h neighbour.h \
+ route.h xroute.h message.h resend.h babel_interface.h babeld.h \
+ babel_filter.h
+
+babeld_SOURCES = \
+ babel_main.c $(libbabel_a_SOURCES)
+
+babeld_LDADD = ../lib/libzebra.la @LIBCAP@
+
+examplesdir = $(exampledir)
+dist_examples_DATA = babeld.conf.sample