summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul P Komkoff Jr <i@stingr.net>2008-09-24 16:42:35 +0100
committerPaul Jakma <paul@quagga.net>2008-09-24 16:42:35 +0100
commit0e9de56d5e5ee44768102f7955e046f4046ef0b7 (patch)
tree6951c65602caf3f2ac646d4d5996641a220f3097 /configure.ac
parent1a7dcf42a244d758732464be389f5cdb1358b9e4 (diff)
[build] Fix --enable-pie so it can actually be disabled
Signed-off-by: Paul Jakma <paul@quagga.net>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 547b6866..6d824f54 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1390,10 +1390,8 @@ CONFDATE=`date '+%Y%m%d'`
AC_SUBST(CONFDATE)
dnl Conditionally enable PIE support for GNU toolchains.
-enable_pie=yes
-
AC_ARG_ENABLE(pie, AS_HELP_STRING([--disable-pie], [Do not build tools as a Position Independent Executables]))
-if test "$enable_pie" = "yes"; then
+if test "$enable_pie" != "no"; then
AC_CACHE_CHECK([whether $CC accepts PIE flags], [ap_cv_cc_pie], [
save_CFLAGS=$CFLAGS
save_LDFLAGS=$LDFLAGS