summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-05-20 00:03:33 +0000
committerpaul <paul>2003-05-20 00:03:33 +0000
commit408ad94329479216806545842c0e5f23241406b2 (patch)
treef6debd6aa63aeebdc49bcf8347db3a334db25247 /configure.ac
parentf04385215b363f57ed3d3dd8f6bfa53ac4e2c1da (diff)
Cleanup the openpam AC_MSG's slightly.
Add a DATE AC_SUBST.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index bdc87e3c..aa9bac00 100755
--- a/configure.ac
+++ b/configure.ac
@@ -224,25 +224,17 @@ dnl ----------
dnl PAM module
dnl ----------
if test "$with_libpam" = "yes"; then
- AC_MSG_CHECKING(security/pam_misc.h)
AC_CHECK_HEADER(security/pam_misc.h)
if test "$ac_cv_header_security_pam_misc_h" = yes; then
AC_DEFINE(HAVE_PAM_MISC_H,,Have pam_misc.h)
AC_DEFINE(PAM_CONV_FUNC,misc_conv,Have misc_conv)
pam_conv_func="misc_conv"
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
fi
- AC_MSG_CHECKING(security/openpam.h)
AC_CHECK_HEADER(security/openpam.h)
if test "$ac_cv_header_security_openpam_h" = yes; then
AC_DEFINE(HAVE_OPENPAM_H,,Have openpam.h)
AC_DEFINE(PAM_CONV_FUNC,openpam_ttyconv,Have openpam_ttyconv)
pam_conv_func="openpam_ttyconv"
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
fi
if test -z "$ac_cv_header_security_pam_misc_h$ac_cv_header_security_openpam_h" ; then
AC_MSG_WARN([*** pam support will not be built ***])
@@ -836,6 +828,12 @@ file="${srcdir}/lib/version.h"
VERSION=`sed -ne 's/^#.*ZEBRA_VERSION.*\"\([^\"]*\)\"$/\1/p' $file`
AC_SUBST(VERSION)
+dnl ----------
+dnl configure date
+dnl ----------
+CONFDATE=`date '+%Y%m%d'`
+AC_SUBST(CONFDATE)
+
dnl ------------------------------
dnl set paths for process id files
dnl ------------------------------