summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Jackson <jerj@coplanar.net>2009-01-21 20:29:39 -0500
committerPaul Jakma <paul@quagga.net>2009-06-19 15:03:31 +0100
commite84999d93afd0f727f7325431c055cc26c988c68 (patch)
tree68bc98d88a07c0dcdd6a0eba644515e8f6247111 /configure.ac
parent5589ffa7dd6846a83e1d312f3dc3f2aa47e40f92 (diff)
[configure] remove unused/broken autoconf cache variable ac_statedir
It wasn't used, and the code wasn't printing progress or the result in some cases. the test uses minimal resources, so it's probably better to not cache so as to avoid inconsistencies if --with-prefix or directory variables are changed between ./configure runs.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 16aad98c..63cef65b 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1444,14 +1444,14 @@ AC_SUBST(PILDFLAGS)
dnl ------------------------------
dnl set paths for state directory
dnl ------------------------------
+AC_MSG_CHECKING(directory to use for state file)
if test "${prefix}" = "NONE"; then
quagga_statedir_prefix="";
else
quagga_statedir_prefix=${prefix}
fi
if test "${localstatedir}" = '${prefix}/var'; then
- AC_CACHE_CHECK(state directory,ac_statedir,
- [for QUAGGA_STATE_DIR in ${quagga_statedir_prefix}/var/run dnl
+ for QUAGGA_STATE_DIR in ${quagga_statedir_prefix}/var/run dnl
${quagga_statedir_prefix}/var/adm dnl
${quagga_statedir_prefix}/etc dnl
/var/run dnl
@@ -1461,16 +1461,15 @@ if test "${localstatedir}" = '${prefix}/var'; then
do
test -d $QUAGGA_STATE_DIR && break
done
- quagga_statedir=$QUAGGA_STATE_DIR])
+ quagga_statedir=$QUAGGA_STATE_DIR
else
quagga_statedir=${localstatedir}
- AC_MSG_CHECKING(directory to use for state file)
- AC_MSG_RESULT(${quagga_statedir})
- AC_SUBST(quagga_statedir)
fi
if test $quagga_statedir = "/dev/null"; then
AC_MSG_ERROR('STATE DIRECTORY NOT FOUND! FIX OR SPECIFY --localstatedir!')
fi
+AC_MSG_RESULT(${quagga_statedir})
+AC_SUBST(quagga_statedir)
AC_DEFINE_UNQUOTED(PATH_ZEBRA_PID, "$quagga_statedir/zebra.pid",zebra PID)
AC_DEFINE_UNQUOTED(PATH_RIPD_PID, "$quagga_statedir/ripd.pid",ripd PID)