summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorStephen Hemminger <shemminger@vyatta.com>2010-01-27 12:38:16 +0300
committerDenis Ovsienko <infrastation@yandex.ru>2010-01-27 12:38:16 +0300
commitdca6c883ea6219460efbe3dadde4b8b9cb12c845 (patch)
tree71352e214bd59277a50a43779bb2cbafbace6cc3 /lib/Makefile.am
parent3f3dc2bd5f8cbde24cb581ed0aed0e372bfd556c (diff)
lib: undo the last PIE commit
Stephen: A recent change breaks build Quagga on Debian Lenny with amd64 (but not i386). Not sure whether this is cause by ld, gcc, or libtool; but whatever it just won't work for a large number of users. Mathias: I would guess it's a problem of libtool because it adds "-fPIC -DPIC" to the compiler flags but doesn't remove -fPIE. That wouldn't be a problem if the compiler would ignore the -fPIE in favor to the latter -fPIC, but obviously it does not. [...] Those objects were actually compiled with -fPIC but also -fPIE which seems to confuse gcc.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 6264878e..315e919b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -14,9 +14,6 @@ libzebra_la_SOURCES = \
zclient.c sockopt.c smux.c md5.c if_rmap.c keychain.c privs.c \
sigevent.c pqueue.c jhash.c memtypes.c workqueue.c
-AM_CFLAGS = $(PICFLAGS)
-AM_LDFLAGS = $(PILDFLAGS)
-
BUILT_SOURCES = memtypes.h route_types.h
libzebra_la_DEPENDENCIES = @LIB_REGEX@