summaryrefslogtreecommitdiff
path: root/vtysh/Makefile.am
diff options
context:
space:
mode:
authorgdt <gdt>2004-06-30 14:25:12 +0000
committergdt <gdt>2004-06-30 14:25:12 +0000
commitfc9d074576c89299cb624b49810b52eda2da9b2c (patch)
tree9e83c1c0ecbd4d81313bdfbcd1716983e9825c23 /vtysh/Makefile.am
parentcf3138890672e3ab65d10d50c1bb48ace04f6066 (diff)
Make vtysh work on NetBSD, and minor cleanups:
if --enable-vtysh, look for perl, and substitute into vtysh/extract.pl, rather than assuming perl is in /usr/bin Look for tputs in libtermcap and libcurses, in addition to previously-searched locations. Follow GNU readlines search order. Clean up --enable-vtysh definition in configure.ac. Add vtysh/vtysh_cmds.c to CLEANFILES. This is important if extract.pl fails, so that 'make clean && make' will regenerate vtysh_cmds.c rhather than using the old zero-length file.
Diffstat (limited to 'vtysh/Makefile.am')
-rw-r--r--vtysh/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/vtysh/Makefile.am b/vtysh/Makefile.am
index 9118350e..fea0cb02 100644
--- a/vtysh/Makefile.am
+++ b/vtysh/Makefile.am
@@ -9,6 +9,7 @@ bin_PROGRAMS = vtysh
vtysh_SOURCES = vtysh_main.c vtysh.c vtysh_user.c vtysh_config.c
nodist_vtysh_SOURCES = vtysh_cmd.c
+CLEANFILES = vtysh_cmd.c
noinst_HEADERS = vtysh.h vtysh_user.h
vtysh_LDADD = ../lib/libzebra.a @LIBCAP@