summaryrefslogtreecommitdiff
path: root/zebra/Makefile.am
diff options
context:
space:
mode:
authorgdt <gdt>2004-06-30 17:36:11 +0000
committergdt <gdt>2004-06-30 17:36:11 +0000
commit87efd646ffef693235d9d29b005a1467373c51bd (patch)
tree85d43e323abb1de6b1ddb6e889f9d580fdb8546d /zebra/Makefile.am
parentf2bfdee5f9db5363fcd13763eca3fda729067d57 (diff)
Add libtool support.
libzebra and libospfapiclient are now built shared, and linked shared with the daemons. This reduces the memory needed when running multiple daemons; each daemon is at least 150k smaller. Static libraries are still built, and libtool should use them on platforms which don't have shared libaries. As with autoconf, the user of a distribution does not need libtool; one just needs that to build from CVS. libospf.a is still a non-shared library, and still installed, not because that makese sense, but because I don't understand why it is the way it is now. Note that the tree was tagged 'libtool-before' just before this commit.
Diffstat (limited to 'zebra/Makefile.am')
-rw-r--r--zebra/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/zebra/Makefile.am b/zebra/Makefile.am
index 6b494e75..0782894c 100644
--- a/zebra/Makefile.am
+++ b/zebra/Makefile.am
@@ -30,7 +30,7 @@ noinst_HEADERS = \
connected.h ioctl.h rib.h rt.h zserv.h redistribute.h debug.h rtadv.h \
interface.h ipforward.h irdp.h
-zebra_LDADD = ../lib/libzebra.a $(otherobj) $(LIBCAP) $(LIB_IPV6)
+zebra_LDADD = $(otherobj) $(LIBCAP) $(LIB_IPV6) -L../lib -lzebra
zebra_DEPENDENCIES = $(otherobj)
@@ -42,8 +42,8 @@ EXTRA_DIST = if_ioctl.c if_ioctl_solaris.c if_netlink.c if_proc.c \
ioctl.c ioctl_solaris.c \
GNOME-SMI GNOME-PRODUCT-ZEBRA-MIB
-#client : client_main.o ../lib/libzebra.a
-# $(CC) -g -o client client_main.o ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
+#client : client_main.o -L../lib -lzebra
+# $(CC) -g -o client client_main.o -L../lib -lzebra $(LIBS) $(LIB_IPV6)
quaggaconfdir = $(sysconfdir)