summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 547b6866..6d824f54 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1390,10 +1390,8 @@ CONFDATE=`date '+%Y%m%d'`
AC_SUBST(CONFDATE)
dnl Conditionally enable PIE support for GNU toolchains.
-enable_pie=yes
-
AC_ARG_ENABLE(pie, AS_HELP_STRING([--disable-pie], [Do not build tools as a Position Independent Executables]))
-if test "$enable_pie" = "yes"; then
+if test "$enable_pie" != "no"; then
AC_CACHE_CHECK([whether $CC accepts PIE flags], [ap_cv_cc_pie], [
save_CFLAGS=$CFLAGS
save_LDFLAGS=$LDFLAGS