summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 60186d98..274ba7a8 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
## Copyright (c) 1996, 97, 98, 99, 2000 Kunihiro Ishiguro <kunihiro@zebra.org>
## Portions Copyright (c) 2003 Paul Jakma <paul@dishone.st>
##
-## $Id: configure.ac,v 1.114 2005/11/11 10:28:59 paul Exp $
+## $Id: configure.ac,v 1.115 2005/11/14 14:05:36 paul Exp $
AC_PREREQ(2.53)
AC_INIT(Quagga, 0.99.2, [http://bugzilla.quagga.net])
@@ -88,7 +88,7 @@ dnl ---------------------------------------------
dnl
if test "x$cflags_specified" = "x" ; then
if test "x${GCC}" = "xyes" && test "x${ICC}" = "xno"; then
- CFLAGS="-Os -fno-omit-frame-pointer -g -Wall"
+ CFLAGS="-Os -fno-omit-frame-pointer -g -std=c99 -Wall"
CFLAGS="${CFLAGS} -Wsign-compare -Wpointer-arith"
CFLAGS="${CFLAGS} -Wbad-function-cast -Wwrite-strings"
CFLAGS="${CFLAGS} -Wmissing-prototypes -Wmissing-declarations"
@@ -324,7 +324,7 @@ AC_HEADER_STDC
AC_CHECK_HEADERS([string.h stropts.h sys/conf.h sys/ksym.h sys/time.h \
sys/times.h sys/select.h sys/sysctl.h sys/sockio.h \
sys/types.h linux/version.h kvm.h netdb.h asm/types.h \
- sys/param.h libutil.h limits.h])
+ sys/param.h libutil.h limits.h stdint.h])
AC_CHECK_HEADERS([sys/socket.h netinet/in_systm.h netinet/in.h \
net/if_dl.h net/netopt.h inet/nd.h net/route.h \