summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f4966d80..fe127a47 100755
--- a/configure.ac
+++ b/configure.ac
@@ -163,10 +163,11 @@ AC_CACHE_CHECK([if ${MAKE-make} is GNU make], [quagga_cv_gnu_make],
]
)
-dnl ---------
-dnl AIX check
-dnl ---------
+dnl -----------------
+dnl System extensions
+dnl -----------------
AC_AIX
+AC_GNU_SOURCE
dnl -------
dnl libtool
@@ -640,7 +641,10 @@ AC_FUNC_REALLOC
AC_FUNC_STAT
AC_FUNC_SELECT_ARGTYPES
AC_FUNC_STRFTIME
-AC_FUNC_STRNLEN
+dnl Avoid AC_FUNC_STRNLEN because it pulls in AC_SYSTEM_EXTENSIONS which
+dnl can lead to strange side effects. So we just check for strnlen
+dnl directly, see below.
+dnlAC_FUNC_STRNLENdnl
AC_FUNC_VPRINTF
dnl -------------------------------
@@ -665,7 +669,7 @@ dnl ---------------
dnl other functions
dnl ---------------
AC_CHECK_FUNCS([dup2 ftruncate getcwd gethostbyname getpagesize gettimeofday \
- inet_ntoa inet_aton \
+ inet_ntoa inet_aton strnlen \
memchr memmove memset select socket \
strcasecmp strchr strcspn strdup strerror \
strncasecmp strndup strrchr strspn strstr \