summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 425fe273..9bbe89f3 100755
--- a/configure.ac
+++ b/configure.ac
@@ -272,6 +272,8 @@ AC_ARG_ENABLE(time-check,
[ --disable-time-check disable slow thread warning messages])
AC_ARG_ENABLE(pcreposix,
[ --enable-pcreposix enable using PCRE Posix libs for regex functions])
+AC_ARG_ENABLE(fpm,
+[ --enable-fpm enable Forwarding Plane Manager support])
if test x"${enable_gcc_ultra_verbose}" = x"yes" ; then
CFLAGS="${CFLAGS} -W -Wcast-qual -Wstrict-prototypes"
@@ -292,6 +294,10 @@ if test x"${enable_time_check}" != x"no" ; then
fi
fi
+if test "${enable_fpm}" = "yes"; then
+ AC_DEFINE(HAVE_FPM,,Forwarding Plane Manager support)
+fi
+
if test "${enable_broken_aliases}" = "yes"; then
if test "${enable_netlink}" = "yes"
then
@@ -828,6 +834,7 @@ fi
AC_SUBST(RT_METHOD)
AC_SUBST(KERNEL_METHOD)
AC_SUBST(OTHER_METHOD)
+AM_CONDITIONAL([HAVE_NETLINK], [test "x$netlink" = "xyes"])
dnl --------------------------
dnl Determine IS-IS I/O method