summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ef24dc00..b3fd50ec 100755
--- a/configure.ac
+++ b/configure.ac
@@ -209,11 +209,7 @@ AC_CHECK_HEADERS([sys/socket.h netinet/in_systm.h netinet/in.h \
net/if_dl.h net/netopt.h inet/nd.h net/route.h \
net/if.h net/if_var.h netinet/in_var.h])
-if test "x${enable_ipv6}" = "xyes"; then
-AC_CHECK_HEADERS([netinet6/in6.h netinet/in6_var.h netinet/icmp6.h \
- netinet6/in6_var.h netinet6/nd6.h])
-fi
-dnl if enable_ipv6
+dnl V6 headers are checked below, after we check for v6
dnl check some types
AC_C_CONST
@@ -637,6 +633,14 @@ dnl -----------------------
fi
fi
+dnl ------------------
+dnl IPv6 header checks
+dnl ------------------
+if test "x${zebra_cv_ipv6}" = "xyes"; then
+AC_CHECK_HEADERS([netinet6/in6.h netinet/in6_var.h netinet/icmp6.h \
+ netinet6/in6_var.h netinet6/nd6.h])
+fi
+
dnl --------------------
dnl Daemon disable check
dnl --------------------