summaryrefslogtreecommitdiff
path: root/isisd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'isisd/Makefile.am')
-rw-r--r--isisd/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/isisd/Makefile.am b/isisd/Makefile.am
new file mode 100644
index 00000000..b9a0c7cb
--- /dev/null
+++ b/isisd/Makefile.am
@@ -0,0 +1,55 @@
+## Process this file with automake to produce Makefile.in.
+
+# INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib -Itopology
+INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib
+DEFS = @DEFS@ -DSYSCONFDIR=\"$(sysconfdir)/\"
+INSTALL_SDATA=@INSTALL@ -m 600
+LIBS = @LIBS@
+noinst_LIBRARIES = libisis.a
+sbin_PROGRAMS = isisd
+
+libisis_a_SOURCES = \
+ isis_adjacency.c isis_lsp.c dict.c isis_circuit.c isis_pdu.c \
+ isis_tlv.c isisd.c isis_misc.c isis_network.c isis_zebra.c isis_dr.c \
+ isis_flags.c isis_dynhn.c iso_checksum.c isis_csm.c isis_events.c \
+ isis_spf.c isis_route.c isis_routemap.c
+
+
+noinst_HEADERS = \
+ isisd.h isis_pdu.h isis_tlv.h isis_adjacency.h isis_constants.h \
+ isis_lsp.h dict.h isis_circuit.h isis_misc.h isis_network.h \
+ isis_zebra.h isis_dr.h isis_flags.h isis_dynhn.h isis_common.h \
+ iso_checksum.h isis_csm.h isis_events.h isis_spf.h isis_route.h
+
+isisd_SOURCES = \
+ isis_main.c $(libisis_a_SOURCES)
+
+isisd_LDADD = ../lib/libzebra.a
+
+sysconf_DATA = isisd.conf.sample
+
+EXTRA_DIST = $(sysconf_DATA)
+
+install-sysconfDATA: $(sysconf_DATA)
+ @$(NORMAL_INSTALL)
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
+ @list='$(sysconf_DATA)'; for p in $$list; do \
+ if test -f $(srcdir)/$$p; then \
+ echo " $(INSTALL_SDATA) $(srcdir)/$$p $(DESTDIR)$(sysconfdir)/$$p"; \
+ $(INSTALL_SDATA) $(srcdir)/$$p $(DESTDIR)$(sysconfdir)/$$p; \
+ else if test -f $$p; then \
+ echo " $(INSTALL_SDATA) $$p $(DESTDIR)$(sysconfdir)/$$p"; \
+ $(INSTALL_SDATA) $$p $(DESTDIR)$(sysconfdir)/$$p; \
+ fi; fi; \
+ done
+
+depend:
+ @$(CPP) -MM $(INCLUDES) $(LDFLAGS) *.c
+
+## File dependency.
+isis_adjacency.o : isis_adjacency.c ../lib/version.h ../lib/log.h \
+ ../isisd/isis_adjacency.h
+isis_pdu.o : isis_pdu.c ../lib/log.h ../isisd/isisd.h \
+ ../isisd/isis_constants.h ../isisd/isis_adjacency.h \
+ ../isisd/isis_pdu.h
+isis_circuit.o : isis_circuit.c ../isisd/isis_circuit.h