summaryrefslogtreecommitdiff
path: root/isisd/topology/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'isisd/topology/Makefile.am')
-rw-r--r--isisd/topology/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/isisd/topology/Makefile.am b/isisd/topology/Makefile.am
new file mode 100644
index 00000000..045c15c8
--- /dev/null
+++ b/isisd/topology/Makefile.am
@@ -0,0 +1,23 @@
+## Process this file with automake to produce Makefile.in.
+
+INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib
+DEFS = @DEFS@ -DSYSCONFDIR=\"$(sysconfdir)/\"
+
+noinst_LIBRARIES = libtopology.a
+
+libtopology_a_SOURCES = \
+ spgrid.c
+
+libtopology_a_DEPENDENCIES = @LIB_REGEX@
+
+libtopology_a_LIBADD = @LIB_REGEX@ ../../lib/libzebra.a
+
+noinst_HEADERS = \
+ spgrid.h
+
+EXTRA_DIST = regex.c regex-gnu.h
+
+depend:
+ @$(CPP) -MM $(INCLUDES) $(LDFLAGS) *.c
+
+## File dependency.