summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 14f7bef1..153922b9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,14 +1,14 @@
AUTOMAKE_OPTIONS = dejagnu
export DEJAGNU
+DEJATOOL =
-SUBDIRS =
+SUBDIRS = bgpd.tests
EXTRA_DIST = \
config/unix.exp \
+ lib/bgpd.exp \
global-conf.exp
-DEJATOOL =
-
INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib -I$(top_builddir)/lib
DEFS = @DEFS@ $(LOCAL_OPTS) -DSYSCONFDIR=\"$(sysconfdir)/\"
@@ -17,6 +17,7 @@ AM_LDFLAGS = $(PILDFLAGS)
if BGPD
TESTS_BGPD = aspathtest testbgpcap ecommtest testbgpmpattr testbgpmpath
+DEJATOOL += bgpd
else
TESTS_BGPD =
endif