summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index cd6b2f1b..7bc880b5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,9 +4,15 @@ DEFS = @DEFS@ $(LOCAL_OPTS) -DSYSCONFDIR=\"$(sysconfdir)/\"
AM_CFLAGS = $(PICFLAGS)
AM_LDFLAGS = $(PILDFLAGS)
+if BGPD
+TESTS_BGPD = aspathtest testbgpcap ecommtest testbgpmpattr testbgpmpath
+else
+TESTS_BGPD =
+endif
+
noinst_PROGRAMS = testsig testbuffer testmemory heavy heavywq heavythread \
- aspathtest testprivs teststream testbgpcap ecommtest \
- testbgpmpattr testchecksum testbgpmpath tabletest
+ testprivs teststream testchecksum tabletest \
+ $(TESTS_BGPD)
testsig_SOURCES = test-sig.c
testbuffer_SOURCES = test-buffer.c