summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2003-06-04 10:19:12 +0000
committerpaul <paul>2003-06-04 10:19:12 +0000
commit0537f4e78d66129d61ae8441a574255165497ba8 (patch)
treed42251cf08acdb89df897051f0f762af100e1082 /Makefile.am
parentfb2d1502bb0893f2aaccb49fb39521974078d96a (diff)
2003-06-04 Paul Jakma <paul@dishone.st>
* (Makefile.am): doc should be a SUBDIR. Specify DIST_SUBDIRS to remove dependence of make dist on configure options. Add doc/mpls to EXTRA_DIST. redhat/ does not need a dist-hook, its already in SUBDIR. Remove CVS/ dir from the dist doc/.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b9b43552..6d9d864c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,15 +1,19 @@
## Process this file with automake to produce Makefile.in.
-SUBDIRS = lib @ZEBRA@ @BGPD@ @RIPD@ @RIPNGD@ @OSPFD@ @OSPF6D@ @VTYSH@ @OSPFCLIENT@ doc
+SUBDIRS = lib @ZEBRA@ @BGPD@ @RIPD@ @RIPNGD@ @OSPFD@ @OSPF6D@ \
+ @VTYSH@ @OSPFCLIENT@ doc
+
+DIST_SUBDIRS = lib zebra bgpd ripd ripngd ospfd ospf6d vtysh \
+ ospfclient doc
EXTRA_DIST = aclocal.m4 SERVICES TODO REPORTING-BUGS vtysh/Makefile.in \
- vtysh/Makefile.am update-autotools
+ vtysh/Makefile.am update-autotools doc/mpls
dist-hook:
mkdir $(distdir)/tools
cp -p $(srcdir)/tools/*.pl $(distdir)/tools
cp -p $(srcdir)/tools/*.el $(distdir)/tools
cp -p $(srcdir)/tools/*.cgi $(distdir)/tools
- mkdir $(distdir)/redhat
cp -p $(srcdir)/redhat/*.init $(distdir)/redhat
cp -p $(srcdir)/redhat/zebra.* $(distdir)/redhat
+ rm -rf `find $(distdir)/doc -type d -name CVS`