summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2003-12-30 11:09:00 +0000
committerpaul <paul>2003-12-30 11:09:00 +0000
commit41ad87809198dfb2cfc769d77592afaf41a2f8f0 (patch)
tree2463895c60eb20e4deec0baeafee8f993a84e951 /Makefile.am
parent10d60ad1ca677a298902beb83387363bb863fd68 (diff)
2003-12-30 Paul Jakma <paul@dishone.st>
* Makefile.am: put the redhat/ stuff into EXTRA_DIST rather than copying via dist-hook. Remove ~ files backup cruft from dists. isisd/Makefile.am: sysconf example should go via dist_examples_DATA. The include-netbsd/ headers werent mentioned as sources and werent being copied into dists.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 46cabb25..6af673cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,13 +8,14 @@ DIST_SUBDIRS = lib zebra bgpd ripd ripngd ospfd ospf6d vtysh \
isisd
EXTRA_DIST = aclocal.m4 SERVICES TODO REPORTING-BUGS vtysh/Makefile.in \
- vtysh/Makefile.am update-autotools doc/mpls
+ vtysh/Makefile.am update-autotools doc/mpls \
+ redhat/quagga.* redhat/*.init
dist-hook:
mkdir $(distdir)/tools
cp -p $(srcdir)/tools/*.pl $(distdir)/tools
cp -p $(srcdir)/tools/*.el $(distdir)/tools
cp -p $(srcdir)/tools/*.cgi $(distdir)/tools
- cp -p $(srcdir)/redhat/*.init $(distdir)/redhat
- cp -p $(srcdir)/redhat/quagga.* $(distdir)/redhat
rm -rf `find $(distdir)/doc -type d -name CVS`
+ rm -rf `find $(distdir)/ -type f -name "*~"`
+