summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Jakma <paul@quagga.net>2012-03-08 13:51:21 +0000
committerPaul Jakma <paul@quagga.net>2012-03-08 16:14:13 +0000
commitfa482834ea1a30eff056dbf0f36a6f3262460a08 (patch)
treecdabf37152e29e05724d54e4ed6bb783b0d9472e /Makefile.am
parent096259d0623ad1a30c5da139af180909b322c91f (diff)
HACKING.tex: Change to a LaTeX version of HACKING
* configure.ac: Check for latexmk and pdflatex * Makefile.am: Add a conditional target to build HACKING.pdf, as a convenience * HACKING.tex: A slightly more structured HACKING, is readable on its own. * HACKING: removed
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 007758f2..ff4c3541 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,4 +14,14 @@ EXTRA_DIST = aclocal.m4 SERVICES TODO REPORTING-BUGS INSTALL.quagga.txt \
tools/mrlg.cgi tools/rrcheck.pl tools/rrlookup.pl tools/zc.pl \
tools/zebra.el tools/multiple-bgpd.sh
+if HAVE_LATEX
+
+HACKING.pdf: HACKING.tex
+ $(LATEXMK) -pdf $<
+
+clean-local:
+ -$(LATEXMK) -C HACKING.tex
+
+endif
+
ACLOCAL_AMFLAGS = -I m4