summaryrefslogtreecommitdiff
path: root/bgpd/Makefile.am
diff options
context:
space:
mode:
authorgdt <gdt>2004-06-30 17:36:11 +0000
committergdt <gdt>2004-06-30 17:36:11 +0000
commit87efd646ffef693235d9d29b005a1467373c51bd (patch)
tree85d43e323abb1de6b1ddb6e889f9d580fdb8546d /bgpd/Makefile.am
parentf2bfdee5f9db5363fcd13763eca3fda729067d57 (diff)
Add libtool support.
libzebra and libospfapiclient are now built shared, and linked shared with the daemons. This reduces the memory needed when running multiple daemons; each daemon is at least 150k smaller. Static libraries are still built, and libtool should use them on platforms which don't have shared libaries. As with autoconf, the user of a distribution does not need libtool; one just needs that to build from CVS. libospf.a is still a non-shared library, and still installed, not because that makese sense, but because I don't understand why it is the way it is now. Note that the tree was tagged 'libtool-before' just before this commit.
Diffstat (limited to 'bgpd/Makefile.am')
-rw-r--r--bgpd/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/bgpd/Makefile.am b/bgpd/Makefile.am
index 9cb3a90f..c243bfa5 100644
--- a/bgpd/Makefile.am
+++ b/bgpd/Makefile.am
@@ -24,7 +24,7 @@ noinst_HEADERS = \
bgpd_SOURCES = \
bgp_main.c $(libbgp_a_SOURCES)
-bgpd_LDADD = ../lib/libzebra.a @LIBCAP@
+bgpd_LDADD = -L../lib -lzebra @LIBCAP@
examplesdir = $(exampledir)
dist_examples_DATA = bgpd.conf.sample bgpd.conf.sample2