summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-03-18 00:03:05 +0000
committerpaul <paul>2003-03-18 00:03:05 +0000
commit07661cb5a81a46c9a177bbc0d963a6a74fbbce43 (patch)
treec6879c4d9bd2a70f929f5dc3261d89b1b0977f7c /configure.ac
parent1b5d019a115bcf69786c870feb93f685ce806ff0 (diff)
Fix build for net-snmp
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c274a0df..4c302121 100755
--- a/configure.ac
+++ b/configure.ac
@@ -617,6 +617,19 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
LIBS="${old_libs}"
fi
+ if test "${HAVE_SNMP}" = ""; then
+ if test "${NEED_CRYPTO}" = ""; then
+ old_libs="${LIBS}"
+ LIBS="-L/usr/lib"
+ AC_CHECK_LIB(netsnmp, asn_parse_int, [HAVE_NETSNMP=yes; HAVE_SNMP=yes ])
+ LIBS="${old_libs}"
+ else
+ old_libs="${LIBS}"
+ LIBS="-L/usr/lib"
+ AC_CHECK_LIB(netsnmp, asn_parse_int, [HAVE_NETSNMP=yes; HAVE_SNMP=yes; NEED_CRYPTO=yes;LIBS="$LIBS -lcrypto" ],,"-lcrypto")
+ LIBS="${old_libs}"
+ fi
+ fi
if test "${HAVE_SNMP}" = "yes"; then
for ac_snmp in /usr/include/net-snmp/library/asn1.h /usr/include/ucd-snmp/asn1.h /usr/local/include/ucd-snmp/asn1.h /dev/null
do
@@ -626,8 +639,13 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
/usr/include/net-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
AC_DEFINE(UCD_COMPATIBLE,,SNMP)
- CFLAGS="${CFLAGS} -I/usr/include/ucd-snmp"
+ CFLAGS="${CFLAGS} -I/usr/include/net-snmp -I/usr/include/net-snmp/library"
+ if test "${HAVE_NETSNMP}" = "yes"; then
+ AC_DEFINE(HAVE_NETSNMP,,SNMP)
+ LIBS="${LIBS} -lnetsnmp"
+ else
LIBS="${LIBS} -lsnmp"
+ fi
;;
/usr/include/ucd-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)