summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorhasso <hasso>2005-03-27 21:00:35 +0000
committerhasso <hasso>2005-03-27 21:00:35 +0000
commit17eff7cb9010c0ba386ab801c220811ded4242b3 (patch)
treec3c0afb627384c4abe0066be933492e74cd272ff /configure.ac
parent1b63904721aa6ca1aabafe23bcf28c5a2ceb2cd8 (diff)
* configure.ac: Fix most of "Presents But Cannot Compiled" warnings
about various headers. CFLAGS is not correct place to specify includes, INCLUDES is for that.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ac79b76c..def16cbe 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
## Copyright (c) 1996, 97, 98, 99, 2000 Kunihiro Ishiguro <kunihiro@zebra.org>
## Portions Copyright (c) 2003 Paul Jakma <paul@dishone.st>
##
-## $Id: configure.ac,v 1.92 2005/03/27 13:07:23 hasso Exp $
+## $Id: configure.ac,v 1.93 2005/03/27 21:00:35 hasso Exp $
AC_PREREQ(2.53)
AC_INIT(Quagga, 0.99.0, [http://bugzilla.quagga.net])
@@ -948,7 +948,7 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
AC_DEFINE(HAVE_SNMP,,SNMP)
AC_DEFINE(HAVE_NETSNMP,,SNMP)
AC_DEFINE(UCD_COMPATIBLE,,SNMP)
- CFLAGS="${CFLAGS} -I/usr/include/net-snmp -I/usr/include/net-snmp/library"
+ INCLUDES="${INCLUDES} -I/usr/include/net-snmp -I/usr/include/net-snmp/library"
if test "${HAVE_NETSNMP}" = "yes"; then
LIBS="${LIBS} -lnetsnmp"
else
@@ -957,19 +957,19 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
;;
/usr/include/ucd-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
- CFLAGS="${CFLAGS} -I/usr/include/ucd-snmp"
+ INCLUDES="${INCLUDES} -I/usr/include/ucd-snmp"
LIBS="${LIBS} -lsnmp"
;;
/usr/local/include/ucd-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
- CFLAGS="${CFLAGS} -I/usr/local/include/ucd-snmp"
+ INCLUDES="${INCLUDES} -I/usr/local/include/ucd-snmp"
LIBS="${LIBS} -L/usr/local/lib -lsnmp"
;;
/usr/local/include/net-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
AC_DEFINE(HAVE_NET_SNMP,,SNMP)
AC_DEFINE(UCD_COMPATIBLE,,SNMP)
- CFLAGS="${CFLAGS} -I/usr/local/include/net-snmp"
+ INCLUDES="${INCLUDES} -I/usr/local/include/net-snmp"
LIBS="${LIBS} -L/usr/local/lib -lnetsnmp"
;;
esac
@@ -1280,6 +1280,7 @@ host operationg system : ${host_os}
source code location : ${srcdir}
compiler : ${CC}
compiler flags : ${CFLAGS}
+includes : ${INCLUDES}
linker flags : ${LDFLAGS} ${LIBS}
state file directory : ${quagga_statedir}
config file directory : `eval echo \`echo ${sysconfdir}\``