summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrad Smith <brad@comstyle.com>2012-08-09 00:44:28 +0000
committerDavid Lamparter <equinox@opensourcerouting.org>2012-09-25 05:56:04 +0200
commit1b54f798d3cc359bec036db83c1c9bfab75d1244 (patch)
treeb9a63cbff8cbea31b3972cc011aca1253a526fc1 /configure.ac
parent4bed21c402fa1079301d47811a4579985997c881 (diff)
build: fix autoconf multicast check on OpenBSD
Fix the "BSD struct ip_mreq hack" autoconf test to work with OpenBSD. Signed-off-by: David Lamparter <equinox@opensourcerouting.org>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7764df71..4cc94006 100755
--- a/configure.ac
+++ b/configure.ac
@@ -957,7 +957,7 @@ AC_CHECK_MEMBERS([struct ip_mreqn.imr_ifindex], [], [], QUAGGA_INCLUDES)
AC_MSG_CHECKING([for BSD struct ip_mreq hack])
AC_TRY_COMPILE([#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
-#endif],[#if (defined(__FreeBSD__) && ((__FreeBSD_version >= 500022 && __FreeBSD_version < 700000) || (__FreeBSD_version < 500000 && __FreeBSD_version >= 440000))) || (defined(__NetBSD__) && defined(__NetBSD_Version__) && __NetBSD_Version__ >= 106010000)
+#endif],[#if (defined(__FreeBSD__) && ((__FreeBSD_version >= 500022 && __FreeBSD_version < 700000) || (__FreeBSD_version < 500000 && __FreeBSD_version >= 440000))) || (defined(__NetBSD__) && defined(__NetBSD_Version__) && __NetBSD_Version__ >= 106010000) || defined(__OpenBSD__)
return (0);
#else
#error No support for BSD struct ip_mreq hack detected