summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2004-07-22 18:16:59 +0000
committerpaul <paul>2004-07-22 18:16:59 +0000
commit27eebb3e5713559379ac072d5f36e26044465ab0 (patch)
tree293c56c3ef6b54f0f6fa2081b9041a12afe27604 /configure.ac
parent2ff9e82652fae8c12883e911f148f6c50d5114e8 (diff)
2004-07-22 Paul Jakma <paul@dishone.st>
* configure.ac: modify default CFLAGS to be compiler agnostic build Makefile for tests/ subdir.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 632de2ac..8eacf476 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
## Copyright (c) 1996, 97, 98, 99, 2000 Kunihiro Ishiguro <kunihiro@zebra.org>
## Portions Copyright (c) 2003 Paul Jakma <paul@dishone.st>
##
-## $Id: configure.ac,v 1.55 2004/06/30 17:36:11 gdt Exp $
+## $Id: configure.ac,v 1.56 2004/07/22 18:16:59 paul Exp $
AC_PREREQ(2.53)
AC_INIT(quagga, 0.96.5, [http://bugzilla.quagga.net])
@@ -46,8 +46,11 @@ AC_PROG_CC
dnl -----------------------------------------
dnl If CLFAGS doesn\'t exist set default value
dnl -----------------------------------------
+dnl (Wall is gcc specific... have to make sure
+dnl gcc is being used before setting it)
+dnl
if test "x$cflags_specified" = "x" ; then
- CFLAGS="$CFLAGS -Wall"
+ CFLAGS="$CFLAGS -O"
fi
dnl --------------
@@ -1122,6 +1125,7 @@ AC_OUTPUT(Makefile lib/Makefile zebra/Makefile ripd/Makefile
vtysh/extract.pl
redhat/Makefile redhat/quagga.spec
lib/version.h,
+ tests/Makefile,
[chmod +x vtysh/extract.pl])
echo "