summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-10-23 20:39:50 +0000
committerpaul <paul>2003-10-23 20:39:50 +0000
commit49e3b3c0646bb14b6f6104a2f4f4ab868915ed0a (patch)
tree024b8751f3546a0747a46fc6b79386a9268cfa2e /configure.ac
parent30be80287aeb91e97159aacd48ee90603a9dfef5 (diff)
2003-10-23 Paul Jakma <paul@dishone.st>
* configure.ac: IRIX configure.ac support. Sort of works. sysctl() crashes though (ipforward), there's some kind of odd padding in the PF_ROUTE socket messages and setsockopt() on SOCK_RAW does not work (so ospfd doesnt work).
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ff7ea83e..807cf7c0 100755
--- a/configure.ac
+++ b/configure.ac
@@ -245,7 +245,7 @@ case "$host" in
OTHER_METHOD="mtu_kvm.o"
AC_CHECK_LIB(kvm, main)
;;
- *-irix65)
+ *-irix6.5)
opsys=irix
AC_DEFINE(IRIX_65,,IRIX 6.5)
;;
@@ -344,7 +344,8 @@ dnl AC_CHECK_SIZEOF(long)
dnl ----------------------------
dnl check existance of functions
dnl ----------------------------
-AC_CHECK_FUNCS(bcopy bzero strerror inet_aton daemon snprintf vsnprintf strlcat strlcpy if_nametoindex if_indextoname getifaddrs)
+AC_CHECK_FUNCS(memset memcpy strerror inet_aton daemon snprintf vsnprintf \
+ strlcat strlcpy if_nametoindex if_indextoname getifaddrs)
AC_CHECK_FUNCS(setproctitle, ,
[AC_CHECK_LIB(util, setproctitle,
[LIBS="$LIBS -lutil"
@@ -379,6 +380,10 @@ else
AC_MSG_RESULT(solaris)
KERNEL_METHOD="kernel_socket.o"
RT_METHOD="rt_socket.o"
+ elif test "$opsys" = "irix" ; then
+ AC_MSG_RESULT(irix)
+ KERNEL_METHOD="kernel_socket.o"
+ RT_METHOD="rt_socket.o"
else
AC_TRY_RUN([#include <errno.h>
#include <sys/types.h>
@@ -446,6 +451,9 @@ else
if test "$opsys" = "sol2-6";then
AC_MSG_RESULT(solaris)
IF_METHOD=if_ioctl.o
+ elif test "$opsys" = "irix" ; then
+ AC_MSG_RESULT(irix)
+ IF_METHOD=if_ioctl.o
elif test "$opsys" = "openbsd";then
AC_MSG_RESULT(openbsd)
IF_METHOD=if_ioctl.o