summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDenis Ovsienko <infrastation@yandex.ru>2011-07-15 00:24:15 +0400
committerDenis Ovsienko <infrastation@yandex.ru>2011-07-15 00:24:15 +0400
commit4a1342a56c6fdb90d9af3109afa9442ff0b850d6 (patch)
tree4861a40d03a1eb9f2d6a715771f0307a71a88f3f /configure.ac
parent5112233b7929299b5200ef820d1567f5d7db50e6 (diff)
configure: fix OpenPAM detection
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9e958b1c..4209c0b9 100755
--- a/configure.ac
+++ b/configure.ac
@@ -617,6 +617,13 @@ AC_SUBST(LIBREADLINE)
dnl ----------
dnl PAM module
+dnl
+dnl Quagga detects the PAM library it is built against by checking for a
+dnl functional pam_misc.h (Linux-PAM) or openpam.h (OpenPAM) header. pam_misc.h
+dnl is known to #include pam_appl.h, the standard header of a PAM library, and
+dnl openpam.h doesn't do that, although depends on the header too. Hence a
+dnl little assistance to AC_CHECK_HEADER is necessary for the proper detection
+dnl of OpenPAM.
dnl ----------
if test "$with_libpam" = "yes"; then
AC_CHECK_HEADER([security/pam_misc.h],
@@ -630,7 +637,7 @@ if test "$with_libpam" = "yes"; then
AC_DEFINE(PAM_CONV_FUNC,openpam_ttyconv,Have openpam_ttyconv)
pam_conv_func="openpam_ttyconv"
],
- [], QUAGGA_INCLUDES)
+ [], QUAGGA_INCLUDES[#include <security/pam_appl.h>])
if test -z "$ac_cv_header_security_pam_misc_h$ac_cv_header_security_openpam_h" ; then
AC_MSG_WARN([*** pam support will not be built ***])
with_libpam="no"