summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-03-02 21:19:26 +0000
committerpaul <paul>2003-03-02 21:19:26 +0000
commit569c0f0188168b79044cc8fcba4639585a3be661 (patch)
tree873bf6be6ca17ba3327ab76cf3cb4739792228b4 /configure.ac
parent338a99166f59e474c522d2eb7417b0de57f598d2 (diff)
Updated vtysh_cmd's. Previously, this was only updated in rpm builds.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2e6055e2..3eab5728 100755
--- a/configure.ac
+++ b/configure.ac
@@ -609,11 +609,17 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
LIBS="${old_libs}"
fi
if test "${HAVE_SNMP}" = "yes"; then
- for ac_snmp in /usr/include/ucd-snmp/asn1.h /usr/local/include/ucd-snmp/asn1.h /dev/null
+ for ac_snmp in /usr/include/net-snmp/library/asn1.h /usr/include/ucd-snmp/asn1.h /usr/local/include/ucd-snmp/asn1.h /dev/null
do
test -f "${ac_snmp}" && break
done
case ${ac_snmp} in
+ /usr/include/net-snmp/*)
+ AC_DEFINE(HAVE_SNMP,,SNMP)
+ AC_DEFINE(UCD_COMPATIBLE,,SNMP)
+ CFLAGS="${CFLAGS} -I/usr/include/ucd-snmp"
+ LIBS="${LIBS} -lsnmp"
+ ;;
/usr/include/ucd-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
CFLAGS="${CFLAGS} -I/usr/include/ucd-snmp"