summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorajs <ajs>2005-01-12 16:52:55 +0000
committerajs <ajs>2005-01-12 16:52:55 +0000
commit6cf9df088e10baefe04139897f8745a42ea0c772 (patch)
treefc5e4ab015ccfc944f445399dc1946bf94ac0992 /configure.ac
parentfc43ecc7ba23ddce46b9ec7732ff08cd9e5bcc1b (diff)
2005-01-12 Andrew J. Schorr <ajschorr@alumni.princeton.edu>
* configure.ac: If configure is invoked with --enable-snmp, but the configure script is unable to find SNMP support on the platform, then configure should give an error message and exit.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8b69d700..61a00d95 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
## Copyright (c) 1996, 97, 98, 99, 2000 Kunihiro Ishiguro <kunihiro@zebra.org>
## Portions Copyright (c) 2003 Paul Jakma <paul@dishone.st>
##
-## $Id: configure.ac,v 1.85 2005/01/07 14:17:39 paul Exp $
+## $Id: configure.ac,v 1.86 2005/01/12 16:52:55 ajs Exp $
AC_PREREQ(2.53)
AC_INIT(Quagga, 0.98.0, [http://bugzilla.quagga.net])
@@ -950,6 +950,10 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
fi
fi
+if test "${enable_snmp}" = "yes" -a "${HAVE_SNMP}" != "yes"; then
+ AC_MSG_ERROR([--enable-snmp given, but cannot find support for SNMP])
+fi
+
dnl ----------------------------
dnl check sa_len of sockaddr
dnl ----------------------------