summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Jakma <paul.jakma@sun.com>2008-07-22 21:11:48 +0000
committerPaul Jakma <paul.jakma@sun.com>2008-07-22 21:11:48 +0000
commit750e814693050bc97391eec618aad9db798ee5e8 (patch)
tree03d3e27a68b0593002d8f73609235919c030e426 /configure.ac
parent851a1a5c146b346d8b8f58fe3924baa5c208f865 (diff)
[bgpd] Fix triggerable crash when compiled with --disable-bgp-announce
2008-07-22 Paul Jakma <paul.jakma@sun.com> * HACKING: Document preference for compiler conditional code, over cpp conditional. * configure.ac: DISABLE_BGP_ANNOUNCE always should be defined. * bgp_{packet,route,advertise}.c: change to compiler testing of DISABLE_BGP_ANNOUNCE, rather than cpp. 2008-07-22 MIYAJIMA Mitsuharu <miyajima.mitsuharu@anchor.jp> * bgp_packet.c: (bgp_update_packet_eor) Fix crash triggerable if a bgpd was compiled with --disable-bgp-announce and if GR is advertised by peer.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9cebf48d..746b5cea 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1207,7 +1207,9 @@ case "${enable_solaris}" in
esac
if test "${enable_bgp_announce}" = "no";then
- AC_DEFINE(DISABLE_BGP_ANNOUNCE,,Disable BGP installation to zebra)
+ AC_DEFINE(DISABLE_BGP_ANNOUNCE,1,Disable BGP installation to zebra)
+else
+ AC_DEFINE(DISABLE_BGP_ANNOUNCE,0,Disable BGP installation to zebra)
fi
AC_SUBST(ZEBRA)