summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-06-06 00:30:35 +0000
committerpaul <paul>2003-06-06 00:30:35 +0000
commit8d4aee5d510fab69561dba58dc9fc0b6f1838aa1 (patch)
tree257fbfc9a0d4afd3aede7278ded9ab80713dfd54 /configure.ac
parenta939514c59fe1a56a820e82bc59d82c721076c03 (diff)
2003-06-06 Paul Jakma <paul@dishone.st
* Fix up case of --enable-vty-group not being specified
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 290d8331..3f19601e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -158,13 +158,10 @@ fi
AC_DEFINE_UNQUOTED(ZEBRA_GROUP, "${enable_group}", Zebra Group)
if test x"${enable_vty_group}" = x"yes" ; then
- AC_MSG_ERROR([--enable-vty-group requires a group as argument])
+ AC_MSG_ERROR([--enable-vty-group requires a group as argument, not yes])
fi
-if test "${enable_vty_group}" = ""; then
- AC_MSG_ERROR([--enable-vty-group requires a group as argument])
-fi
-if test x"${enable_vty_group}" != x"no"; then
- if test "${enable_vty_group}" != ""; then
+if test x"${enable_vty_group}" != x""; then
+ if test x"${enable_vty_group}" != x"no"; then
AC_DEFINE_UNQUOTED(VTY_GROUP, "${enable_vty_group}", VTY Sockets Group)
fi
fi
@@ -1023,4 +1020,7 @@ compiler : ${CC}
compiler flags : ${CFLAGS}
linker flags : ${LDFLAGS} ${LIBS}
state file directory : ${zebra_statedir}
+user to run as : ${enable_user}
+group to run as : ${enable_group}
+group for vty sockets : ${enable_vty_group}
"