summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGreg Troxel <gdt@fnord.ir.bbn.com>2007-08-02 13:36:56 +0000
committerGreg Troxel <gdt@fnord.ir.bbn.com>2007-08-02 13:36:56 +0000
commit97cee877c2d3935a6e708dc5a63f43a29cc244ed (patch)
tree38d82b487d1a4e4aabcef2b76cb5b8176e34605b /configure.ac
parent37ccd1467e8500699fb9047c5ba214f7ffbd1347 (diff)
Add --enable-solaris to descend into solaris-specific build directory.
While it doesn't take a long time to build, this is currently the only thing in the tree that doesn't work with BSD make, and there's no reason to build solaris package control files on other systems.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index db6c6dc8..857f4154 100755
--- a/configure.ac
+++ b/configure.ac
@@ -197,6 +197,8 @@ AC_ARG_ENABLE(watchquagga,
[ --disable-watchquagga do not build watchquagga])
AC_ARG_ENABLE(isisd,
[ --enable-isisd build isisd])
+AC_ARG_ENABLE(solaris,
+[ --enable-solaris build solaris])
AC_ARG_ENABLE(bgp-announce,
[ --disable-bgp-announce, turn off BGP route announcement])
AC_ARG_ENABLE(netlink,
@@ -1131,6 +1133,13 @@ case "${enable_isisd}" in
* ) ;;
esac
+# XXX Perhaps auto-enable on Solaris, but that's messy for cross builds.
+case "${enable_solaris}" in
+ "yes") SOLARIS="solaris";;
+ "no" ) SOLARIS="";;
+ * ) ;;
+esac
+
if test "${enable_bgp_announce}" = "no";then
AC_DEFINE(DISABLE_BGP_ANNOUNCE,,Disable BGP installation to zebra)
fi
@@ -1143,6 +1152,7 @@ AC_SUBST(OSPFD)
AC_SUBST(OSPF6D)
AC_SUBST(WATCHQUAGGA)
AC_SUBST(ISISD)
+AC_SUBST(SOLARIS)
AC_SUBST(VTYSH)
AC_SUBST(INCLUDES)
AC_SUBST(CURSES)