summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorgdt <gdt>2003-12-22 20:15:53 +0000
committergdt <gdt>2003-12-22 20:15:53 +0000
commitaa593d5e2638566ead1e69381e60639550991ff2 (patch)
treec865f642c1029fa47b8fc6cc86302468b9b2aef4 /configure.ac
parent47ce02a8f12134a6ba515fbf1d2b9276e39d4c06 (diff)
2003-12-22 Christian Hammers <ch@lathspell.de>
* configure.ac (and everywhere a regular file is opened for writing): use file permissions from configure rather than compiled-in umask.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b6d8829f..094da52e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,10 @@ AC_ARG_ENABLE(quagga_group,
[ --enable-group=ARG group to run Quagga suite as (default quagga)])
AC_ARG_ENABLE(vty_group,
[ --enable-vty-group=ARG set vty sockets to have specified group as owner])
+AC_ARG_ENABLE(configfile_mask,
+[ --enable-configfile-mask=ARG set mask for config files])
+AC_ARG_ENABLE(logfile_mask,
+[ --enable-logfile-mask=ARG set mask for log files])
AC_ARG_ENABLE(rtadv,
[ --disable-rtadv disable IPV6 router advertisement feature])
@@ -176,6 +180,12 @@ elif test x"${enable_vty_group}" != x""; then
fi
fi
+enable_configfile_mask=${enable_configfile_mask:-0600}
+AC_DEFINE_UNQUOTED(CONFIGFILE_MASK, ${enable_configfile_mask}, Mask for config files)
+
+enable_logfile_mask=${enable_logfile_mask:-0600}
+AC_DEFINE_UNQUOTED(LOGFILE_MASK, ${enable_logfile_mask}, Mask for log files)
+
changequote(, )dnl
MULTIPATH_NUM=1
@@ -1073,6 +1083,8 @@ example directory : `eval echo \`echo ${exampledir}\``
user to run as : ${enable_user}
group to run as : ${enable_group}
group for vty sockets : ${enable_vty_group}
+config file mask : ${enable_configfile_mask}
+log file mask : ${enable_logfile_mask}
The above user and group must have read/write access to the state file
directory and to the config files in the config file directory.