summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-03-18 14:12:28 +0000
committerpaul <paul>2003-03-18 14:12:28 +0000
commitaa83f278de0d01bc7d9bd4983bbfb1284d03de21 (patch)
treea50090154d17150eb8f5aad50d8732571042a689 /configure.ac
parente06268546466116a17cb655815be21b0d687c4c3 (diff)
Update configure.ac to match configure.in.
still perplexed why removing configure.in breaks certain autoconf sites.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac20
1 files changed, 1 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 4c302121..c274a0df 100755
--- a/configure.ac
+++ b/configure.ac
@@ -617,19 +617,6 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
LIBS="${old_libs}"
fi
- if test "${HAVE_SNMP}" = ""; then
- if test "${NEED_CRYPTO}" = ""; then
- old_libs="${LIBS}"
- LIBS="-L/usr/lib"
- AC_CHECK_LIB(netsnmp, asn_parse_int, [HAVE_NETSNMP=yes; HAVE_SNMP=yes ])
- LIBS="${old_libs}"
- else
- old_libs="${LIBS}"
- LIBS="-L/usr/lib"
- AC_CHECK_LIB(netsnmp, asn_parse_int, [HAVE_NETSNMP=yes; HAVE_SNMP=yes; NEED_CRYPTO=yes;LIBS="$LIBS -lcrypto" ],,"-lcrypto")
- LIBS="${old_libs}"
- fi
- fi
if test "${HAVE_SNMP}" = "yes"; then
for ac_snmp in /usr/include/net-snmp/library/asn1.h /usr/include/ucd-snmp/asn1.h /usr/local/include/ucd-snmp/asn1.h /dev/null
do
@@ -639,13 +626,8 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
/usr/include/net-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
AC_DEFINE(UCD_COMPATIBLE,,SNMP)
- CFLAGS="${CFLAGS} -I/usr/include/net-snmp -I/usr/include/net-snmp/library"
- if test "${HAVE_NETSNMP}" = "yes"; then
- AC_DEFINE(HAVE_NETSNMP,,SNMP)
- LIBS="${LIBS} -lnetsnmp"
- else
+ CFLAGS="${CFLAGS} -I/usr/include/ucd-snmp"
LIBS="${LIBS} -lsnmp"
- fi
;;
/usr/include/ucd-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)