summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-05-28 15:29:10 -0700
committerPaul Jakma <paul@quagga.net>2009-06-18 20:18:31 +0100
commitc4376c9d28f1282f502ed5279ee80ec5c4cb810d (patch)
tree162d6a64033db3702a82a9470549570f1fac4080 /configure.ac
parent8f5abac1c3f5ad18561cad560bd42b50d2419d94 (diff)
[configure] Detect support for monotonic clock
Quagga has code to support monotonic clock to avoid issues where time of day changes. The support was incomplete since it was not being detected by autoconf.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7cf30a80..c1f61824 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1321,6 +1321,16 @@ AC_TRY_COMPILE([#include <sys/resource.h>
AC_DEFINE(HAVE_RUSAGE,,rusage)],
AC_MSG_RESULT(no))
+dnl --------------------------------------
+dnl checking for clock_time monotonic struct and call
+dnl --------------------------------------
+AC_CHECK_LIB(rt, clock_gettime,
+[AC_DEFINE(HAVE_MONOTONIC_CLOCK,, Have monotonic clock)
+ LIBS="$LIBS -lrt"]
+)
+
+
+
dnl -------------------
dnl capabilities checks
dnl -------------------