summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew J. Schorr <ajschorr@alumni.princeton.edu>2008-01-10 15:24:32 +0000
committerAndrew J. Schorr <ajschorr@alumni.princeton.edu>2008-01-10 15:24:32 +0000
commitc543a1737173fb438f1d8c06f650b2d0d479f45c (patch)
treeba940242e22f7e6798e6fd24b19864b5702474db /configure.ac
parent3f087670efa606021cde2f6a9615ac7e07aec2a5 (diff)
[link-detect] Try to get BSD link-detect to work properly.
2008-01-10 Ingo Flaschberger <if@xip.at> * configure.ac: Define HAVE_BSD_LINK_DETECT if <net/if_media.h> is present. * lib/zebra.h: If HAVE_BSD_LINK_DETECT is defined, include <net/if_media.h>. * zebra/ioctl.c: (if_get_flags) If HAVE_BSD_LINK_DETECT, use the SIOCGIFMEDIA ioctl to ascertain link state. * zebra/kernel_socket.c: (bsd_linkdetect_translate) New function to map the ifm_data.ifi_link_state value into the IFF_RUNNING flag. (ifm_read) Call bsd_linkdetect_translate to fix the IFF_RUNNING flag before calling if_flags_update.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a76649b5..7f061bb1 100755
--- a/configure.ac
+++ b/configure.ac
@@ -890,6 +890,13 @@ AC_TRY_COMPILE([#ifdef HAVE_SYS_PARAM_H
AC_DEFINE(HAVE_BSD_STRUCT_IP_MREQ_HACK,,[Can pass ifindex in struct ip_mreq])],
AC_MSG_RESULT(no))
+dnl ---------------------------------------------------------------
+dnl figure out how to check link-state
+dnl ---------------------------------------------------------------
+AC_CHECK_HEADER([net/if_media.h],
+ [AC_DEFINE(HAVE_BSD_LINK_DETECT,,[BSD link-detect])],
+ [], QUAGGA_INCLUDES)
+
dnl -----------------------
dnl check proc file system.
dnl -----------------------