summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Lamparter <equinox@diac24.net>2009-09-16 02:11:00 +0200
committerDenis Ovsienko <infrastation@yandex.ru>2011-12-13 19:12:42 +0400
commitca9f342c2c35523b7bb34631b4f75cad1232355b (patch)
tree597b2299aa3d54ae7907621f5284a49c57001c34 /configure.ac
parenta34eb3689ca0bb88e2ae7b95b01eb8887048ce15 (diff)
build: fixup autoconf for cross-compiling (to OpenWRT)
MALLOC/REALLOC aren't used properly (no rpl_malloc), remove them while at it, infer some sane ipforwarding method from the OS value. (v2 on that, "==" is not a proper operator for standard "test")
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 7a4790ee..4e5b5359 100755
--- a/configure.ac
+++ b/configure.ac
@@ -692,11 +692,9 @@ dnl ----------------------------
AC_FUNC_CHOWN
AC_FUNC_FNMATCH
AC_FUNC_FORK
-AC_FUNC_MALLOC
AC_FUNC_MEMCMP
AC_FUNC_MKTIME
AC_FUNC_STRFTIME
-AC_FUNC_REALLOC
AC_FUNC_STAT
AC_FUNC_SELECT_ARGTYPES
AC_FUNC_STRFTIME
@@ -1008,10 +1006,18 @@ dnl -----------------------------
dnl check ipforward detect method
dnl -----------------------------
AC_CACHE_CHECK([ipforward method], [quagga_cv_ipforward_method],
-[for quagga_cv_ipforward_method in /proc/net/snmp /dev/ip /dev/null;
-do
- test x`ls $quagga_cv_ipforward_method 2>/dev/null` = x"$quagga_cv_ipforward_method" && break
-done
+[if test x$cross_compiling = xyes; then
+ if test x"$opsys" = x"gnu-linux"; then
+ quagga_cv_ipforward_method=/proc/net/snmp
+ else
+ quagga_cv_ipforward_method=/dev/ip
+ fi
+else
+ for quagga_cv_ipforward_method in /proc/net/snmp /dev/ip /dev/null;
+ do
+ test x`ls $quagga_cv_ipforward_method 2>/dev/null` = x"$quagga_cv_ipforward_method" && break
+ done
+fi
case $quagga_cv_ipforward_method in
"/proc/net/snmp") quagga_cv_ipforward_method="proc";;
"/dev/ip")