summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoakim Tjernlund <Joakim.Tjernlund@transmode.se>2009-02-16 09:40:39 +0100
committerPaul Jakma <paul@quagga.net>2009-06-25 14:01:19 +0100
commitcbcd9bfc503f08b99f5360b1aae3a5362d25a665 (patch)
tree58814eea77d86ddbca739dd005c9adb802611864 /configure.ac
parent3d8617b853af511ca5f019b2f51c7902e2689212 (diff)
[doc] Add "--disable-doc" to configure
Configure option "--disable-doc" will prevent building the documents under doc. Saves build time and the need to have document building tools installed. Useful when your build machine is different from your development machine.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cd883d2a..d7d8a2f3 100755
--- a/configure.ac
+++ b/configure.ac
@@ -185,6 +185,8 @@ AC_ARG_ENABLE(vtysh,
[ --enable-vtysh include integrated vty shell for Quagga])
AC_ARG_ENABLE(ipv6,
[ --disable-ipv6 turn off IPv6 related features and daemons])
+AC_ARG_ENABLE(doc,
+[ --disable-doc do not build docs])
AC_ARG_ENABLE(zebra,
[ --disable-zebra do not build zebra daemon])
AC_ARG_ENABLE(bgpd,
@@ -1154,6 +1156,13 @@ QUAGGA_INCLUDES
#endif
])dnl
+dnl disable doc check
+if test "${enable_doc}" = "no";then
+ DOC=""
+else
+ DOC="doc"
+fi
+
dnl --------------------
dnl Daemon disable check
dnl --------------------
@@ -1230,6 +1239,7 @@ else
AC_DEFINE(DISABLE_BGP_ANNOUNCE,0,Disable BGP installation to zebra)
fi
+AC_SUBST(DOC)
AC_SUBST(ZEBRA)
AC_SUBST(BGPD)
AC_SUBST(RIPD)