summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorgdt <gdt>2003-12-03 18:13:48 +0000
committergdt <gdt>2003-12-03 18:13:48 +0000
commitd2a0ccc634dec98d0498c082ba49c069aaee0fae (patch)
tree88e213456e97024349b501d0bf864d2afce1291d /configure.ac
parent4b5e1359cf7dd7a346a5e6848244597e6df4373e (diff)
Enable rtadv by default.
Resolves bug #66.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b3fd50ec..725ce72f 100755
--- a/configure.ac
+++ b/configure.ac
@@ -117,7 +117,7 @@ AC_ARG_ENABLE(vty_group,
[ --enable-vty-group=ARG set vty sockets to have specified group as owner])
AC_ARG_ENABLE(rtadv,
-[ --enable-rtadv enable IPV6 router advertisement feature])
+[ --disable-rtadv disable IPV6 router advertisement feature])
if test "${enable_broken_aliases}" = "yes"; then
if test "${enable_netlink}" = "yes"
@@ -146,10 +146,10 @@ if test "${enable_ospf_te}" = "yes"; then
AC_DEFINE(HAVE_OSPF_TE,,OSPF TE)
fi
-AC_MSG_CHECKING(Should zebra's RTADV be used)
-if test "${enable_rtadv}" = "yes"; then
+AC_MSG_CHECKING(if zebra should be configurable to send Route Advertisements)
+if test "${enable_rtadv}" != "no"; then
AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_RTADV,,Enable zebra IPv6 Routing Advertisements)
+ AC_DEFINE(HAVE_RTADV,,Enable IPv6 Routing Advertisement support)
else
AC_MSG_RESULT(no)
fi