summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorgdt <gdt>2003-12-03 17:24:27 +0000
committergdt <gdt>2003-12-03 17:24:27 +0000
commitd6b72f7ab1d33a43e1b6d5cd3410ac53e3bf74a9 (patch)
treee2b2a025757c52802bc12a4b6b8eec94d4bcdd79 /configure.ac
parent6c110e700c21ef3d1d958da1df54261960d7ef07 (diff)
Add support for --enable-exampledir to specify where to place example
files, defaulting to sysconfdir (matching previous behavior). This is needed to support (cleanly) NetBSD pkgsrc, which requires that example config files go in $(prefix)/share/examples/pkgname, rather than in $(prefix)/etc/pkgname.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 18db4939..ef24dc00 100755
--- a/configure.ac
+++ b/configure.ac
@@ -12,6 +12,15 @@ AC_CONFIG_SRCDIR(lib/zebra.h)
AM_INIT_AUTOMAKE()
AM_CONFIG_HEADER(config.h)
+dnl default is to match previous behavior
+exampledir='${sysconfdir}'
+AC_ARG_ENABLE([exampledir],
+ AC_HELP_STRING([--enable-exampledir],
+ [specify alternate directory for examples]),
+ exampledir="$enableval",)
+dnl XXX hook into argument processing
+AC_SUBST(exampledir)
+
dnl -----------------------------------
dnl Get hostname and other information.
dnl -----------------------------------
@@ -1056,6 +1065,7 @@ compiler flags : ${CFLAGS}
linker flags : ${LDFLAGS} ${LIBS}
state file directory : ${quagga_statedir}
config file directory : `eval echo \`echo ${sysconfdir}\``
+example directory : `eval echo \`echo ${exampledir}\``
user to run as : ${enable_user}
group to run as : ${enable_group}
group for vty sockets : ${enable_vty_group}