summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-10-22 00:07:44 +0000
committerpaul <paul>2003-10-22 00:07:44 +0000
commitdc7a2bf1c831f6bcea5945f7fe2eb2ba111e4224 (patch)
tree345df7e8dd1918560a8c3941d328a62359eb56f5 /configure.ac
parenta384592fda7cec702f8d3201f51b636d6fe1be9b (diff)
2003-10-22 Paul Jakma <paul@dishone.st>
* configure.ac: Split up header checks into non-net, net and ipv6 related. Checking of IPv6 is conditional. Add some more output text for the end of the configure run.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac25
1 files changed, 23 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 992422c9..ff7ea83e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -190,8 +190,21 @@ AC_SUBST(MULTIPATH_NUM)
dnl -------------------
dnl Check header files.
dnl -------------------
-AC_STDC_HEADERS
-AC_CHECK_HEADERS(string.h stropts.h sys/conf.h sys/ksym.h sys/time.h sys/times.h sys/select.h sys/sysctl.h sys/sockio.h sys/types.h net/if_dl.h net/if_var.h linux/version.h kvm.h netdb.h netinet/in.h net/netopt.h netinet/in_var.h netinet/in6_var.h netinet6/in6_var.h netinet/in6.h inet/nd.h asm/types.h netinet/icmp6.h netinet6/nd6.h libutil.h)
+AC_HEADER_STDC
+AC_CHECK_HEADERS([string.h stropts.h sys/conf.h sys/ksym.h sys/time.h \
+ sys/times.h sys/select.h sys/sysctl.h sys/sockio.h \
+ sys/types.h linux/version.h kvm.h netdb.h asm/types.h \
+ libutil.h limits.h])
+
+AC_CHECK_HEADERS([sys/socket.h netinet/in.h net/if_dl.h \
+ net/netopt.h inet/nd.h net/route.h net/if.h \
+ net/if_var.h netinet/in_var.h])
+
+if test "x${enable_ipv6}" = "xyes"; then
+AC_CHECK_HEADERS([netinet6/in6.h netinet/in6_var.h netinet/icmp6.h \
+ netinet6/in6_var.h netinet6/nd6.h])
+fi
+dnl if enable_ipv6
dnl check some types
AC_C_CONST
@@ -232,6 +245,10 @@ case "$host" in
OTHER_METHOD="mtu_kvm.o"
AC_CHECK_LIB(kvm, main)
;;
+ *-irix65)
+ opsys=irix
+ AC_DEFINE(IRIX_65,,IRIX 6.5)
+ ;;
esac
dnl ---------------------
@@ -1022,7 +1039,11 @@ compiler : ${CC}
compiler flags : ${CFLAGS}
linker flags : ${LDFLAGS} ${LIBS}
state file directory : ${quagga_statedir}
+config file directory : `eval echo \`echo ${sysconfdir}\``
user to run as : ${enable_user}
group to run as : ${enable_group}
group for vty sockets : ${enable_vty_group}
+
+The above user and group must have read/write access to the state file
+directory and to the config files in the config file directory.
"