summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Lamparter <equinox@opensourcerouting.org>2012-11-03 09:14:29 -0700
committerDavid Lamparter <equinox@opensourcerouting.org>2012-11-03 09:51:21 -0700
commite2b1580cbc450b55491efd2cf03c967e53e63f5f (patch)
tree111f0d828b16071d69b989c46788efbedaadabcd /configure.ac
parent326fe3df2c659d62fc76f8579a414ba271e7f3e9 (diff)
build: compile tests/ by default
Broke the tests again... let's just build them by default so it's easier to notice. If anyone doesn't want to build tests, there's --disable-tests. NB: tests will be neither run nor installed. Signed-off-by: David Lamparter <equinox@opensourcerouting.org>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4cc94006..dcca9682 100755
--- a/configure.ac
+++ b/configure.ac
@@ -198,6 +198,8 @@ AC_ARG_ENABLE(ipv6,
[ --disable-ipv6 turn off IPv6 related features and daemons])
AC_ARG_ENABLE(doc,
[ --disable-doc do not build docs])
+AC_ARG_ENABLE(tests,
+[ --disable-tests do not build tests])
AC_ARG_ENABLE(zebra,
[ --disable-zebra do not build zebra daemon])
AC_ARG_ENABLE(bgpd,
@@ -1232,6 +1234,13 @@ else
DOC="doc"
fi
+dnl can't use TESTS as name, that's special with automake
+if test "${enable_tests}" = "no";then
+ BUILD_TESTS=""
+else
+ BUILD_TESTS="tests"
+fi
+
dnl --------------------
dnl Daemon disable check
dnl --------------------
@@ -1325,6 +1334,7 @@ else
fi
AC_SUBST(DOC)
+AC_SUBST(BUILD_TESTS)
AC_SUBST(ZEBRA)
AC_SUBST(BGPD)
AC_SUBST(RIPD)