summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Lamparter <equinox@opensourcerouting.org>2013-02-26 16:21:20 +0100
committerDavid Lamparter <equinox@diac24.net>2013-04-14 16:01:05 +0200
commitf281ab9752393fcc7cbb54c50edb66f25c2a31fb (patch)
tree53be958c127d21c6bc0e2e2abd02f33a3fde16c2 /configure.ac
parentf2b53dac4c72811c06779c596c6162b994eb427a (diff)
tests: add DejaGNU framework
DejaGNU seems to be the 'standard' GNU test framework (which by itself doesn't say much), but it seems relatively usable and the "remote system" capabilities might come in handy for virtualisation-based tests for kernel interactions or something. Signed-off-by: David Lamparter <equinox@opensourcerouting.org>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6e59037a..582f3572 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1619,6 +1619,18 @@ fi
AC_SUBST(PICFLAGS)
AC_SUBST(PILDFLAGS)
+dnl -------
+dnl DejaGNU
+dnl -------
+if test x"$DEJAGNU" = x
+then
+ DEJAGNU="\$(top_srcdir)/tests/global-conf.exp"
+fi
+RUNTESTDEFAULTFLAGS="-x --tool \$\$tool"
+
+AC_SUBST(DEJAGNU)
+AC_SUBST(RUNTESTDEFAULTFLAGS)
+
dnl ------------------------------
dnl set paths for state directory
dnl ------------------------------
@@ -1691,8 +1703,8 @@ AC_MSG_RESULT($ac_cv_htonl_works)
AC_CONFIG_FILES([Makefile lib/Makefile zebra/Makefile ripd/Makefile
ripngd/Makefile bgpd/Makefile ospfd/Makefile watchquagga/Makefile
ospf6d/Makefile isisd/Makefile babeld/Makefile vtysh/Makefile
- doc/Makefile ospfclient/Makefile tests/Makefile m4/Makefile
- redhat/Makefile
+ doc/Makefile ospfclient/Makefile tests/Makefile m4/Makefile
+ redhat/Makefile
pkgsrc/Makefile
redhat/quagga.spec
lib/version.h