summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-11-02 07:29:11 +0000
committerpaul <paul>2003-11-02 07:29:11 +0000
commitf3bd1a781dd79265d09d148a9eb31291303fdaae (patch)
tree088d1f231453d5560ab95b578beaeef5b4e1111b /configure.ac
parentb5f4502146e38ee34efa5336ec82b4501a1cf705 (diff)
2003-11-02 Paul Jakma <paul@dishone.st>
* configure.ac: FreeBSD has net-snmp in /usr/local.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5827447f..18db4939 100755
--- a/configure.ac
+++ b/configure.ac
@@ -197,7 +197,7 @@ AC_CHECK_HEADERS([string.h stropts.h sys/conf.h sys/ksym.h sys/time.h \
libutil.h limits.h])
AC_CHECK_HEADERS([sys/socket.h netinet/in_systm.h netinet/in.h \
- net/if_dl.hnet/netopt.h inet/nd.h net/route.h \
+ net/if_dl.h net/netopt.h inet/nd.h net/route.h \
net/if.h net/if_var.h netinet/in_var.h])
if test "x${enable_ipv6}" = "xyes"; then
@@ -792,6 +792,13 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
CFLAGS="${CFLAGS} -I/usr/local/include/ucd-snmp"
LIBS="${LIBS} -L/usr/local/lib -lsnmp"
;;
+ /usr/local/include/net-snmp/*)
+ AC_DEFINE(HAVE_SNMP,,SNMP)
+ AC_DEFINE(HAVE_NET_SNMP,,SNMP)
+ AC_DEFINE(UCD_COMPATIBLE,,SNMP)
+ CFLAGS="${CFLAGS} -I/usr/local/include/net-snmp"
+ LIBS="${LIBS} -L/usr/local/lib -lnetsnmp"
+ ;;
esac
if test "${NEED_CRYPTO}" = "yes"; then
LIBS="${LIBS} -lcrypto"