summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-09-24 05:09:26 +0000
committerpaul <paul>2003-09-24 05:09:26 +0000
commitfa1253d0c95416ab0361e6945275ef8194fd7ddd (patch)
treec0e9455701831fcc436f3b579eca956e07c6686a /configure.ac
parent3e95a0741feb6f8b103577d0019a5db562d8315d (diff)
2003-09-24 Paul Jakma <paul@dishone.st>
* lib/version.h: moved to version.h.in * lib/version.h.in: New file, from version.h. Change hardcoded package name and version to use the autoconf defined substition variables. * configure.ac: Fix up AC/AM_INIT* to new style. Remove the sed'ing through lib/version.h for VERSION. Add lib/version.h to the AC_OUTPUT list. Update the text output of quagga version at end of configure run to use PACKAGE_VERSION. * doc/.cvsignore: ignore quagga.pdf * doc/.cvsignore: ignore version.h, its now autogenerated.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac17
1 files changed, 6 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index fe8e311f..23f7b0a1 100755
--- a/configure.ac
+++ b/configure.ac
@@ -7,8 +7,9 @@
##
AC_PREREQ(2.53)
-AC_INIT(lib/zebra.h)
-AM_INIT_AUTOMAKE(quagga, 0.96.2)
+AC_INIT(quagga, 0.96.2, [bug-zebra@gnu.org])
+AC_CONFIG_SRCDIR(lib/zebra.h)
+AM_INIT_AUTOMAKE()
AM_CONFIG_HEADER(config.h)
dnl -----------------------------------
@@ -935,13 +936,6 @@ if test x"${ac_cv_header_execinfo_h}" = x"yes"; then
)
fi
-dnl -------------
-dnl check version
-dnl -------------
-file="${srcdir}/lib/version.h"
-VERSION=`sed -ne 's/^#.*QUAGGA_VERSION.*\"\([^\"]*\)\"$/\1/p' $file`
-AC_SUBST(VERSION)
-
dnl ----------
dnl configure date
dnl ----------
@@ -1015,12 +1009,13 @@ AC_OUTPUT(Makefile lib/Makefile zebra/Makefile ripd/Makefile
ripngd/Makefile bgpd/Makefile ospfd/Makefile
ospf6d/Makefile vtysh/Makefile doc/Makefile
ospfclient/Makefile
- redhat/quagga.spec)
+ redhat/quagga.spec
+ lib/version.h)
echo "
zebra configuration
-------------------
-quagga version : ${VERSION}
+quagga version : ${PACKAGE_VERSION}
host operationg system : ${host_os}
source code location : ${srcdir}
compiler : ${CC}