summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorgdt <gdt>2004-06-30 14:25:12 +0000
committergdt <gdt>2004-06-30 14:25:12 +0000
commitfc9d074576c89299cb624b49810b52eda2da9b2c (patch)
tree9e83c1c0ecbd4d81313bdfbcd1716983e9825c23 /configure.ac
parentcf3138890672e3ab65d10d50c1bb48ace04f6066 (diff)
Make vtysh work on NetBSD, and minor cleanups:
if --enable-vtysh, look for perl, and substitute into vtysh/extract.pl, rather than assuming perl is in /usr/bin Look for tputs in libtermcap and libcurses, in addition to previously-searched locations. Follow GNU readlines search order. Clean up --enable-vtysh definition in configure.ac. Add vtysh/vtysh_cmds.c to CLEANFILES. This is important if extract.pl fails, so that 'make clean && make' will regenerate vtysh_cmds.c rhather than using the old zero-length file.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac20
1 files changed, 15 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 21294212..bd6b4ff8 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
## Copyright (c) 1996, 97, 98, 99, 2000 Kunihiro Ishiguro <kunihiro@zebra.org>
## Portions Copyright (c) 2003 Paul Jakma <paul@dishone.st>
##
-## $Id: configure.ac,v 1.53 2004/06/20 21:00:27 hasso Exp $
+## $Id: configure.ac,v 1.54 2004/06/30 14:25:12 gdt Exp $
AC_PREREQ(2.53)
AC_INIT(quagga, 0.96.5, [http://bugzilla.quagga.net])
@@ -68,7 +68,7 @@ dnl ----------------------
dnl Packages configuration
dnl ----------------------
AC_ARG_ENABLE(vtysh,
-[ --enable-vtysh, Make integrated vty shell for Quagga])
+[ --enable-vtysh include integrated vty shell for Quagga])
AC_ARG_ENABLE(ipv6,
[ --disable-ipv6 turn off IPv6 related features and daemons])
AC_ARG_ENABLE(zebra,
@@ -286,10 +286,18 @@ dnl ---------------------
case "${enable_vtysh}" in
"yes") VTYSH="vtysh";
AC_DEFINE(VTYSH,,VTY shell)
- AC_CHECK_LIB(tinfo, tputs, , AC_CHECK_LIB(ncurses, tputs))
+ AC_PATH_PROG(PERL, perl)
+dnl Vtysh uses libreadline, which looks for termcap functions at
+dnl configure time. We follow readline's search order.
+dnl The required procedures are in libtermcap on NetBSD, in
+dnl [TODO] on Linux, and in [TODO] on Solaris.
+ AC_CHECK_LIB(termcap, tputs, ,
+ AC_CHECK_LIB(tinfo, tputs, ,
+ AC_CHECK_LIB(curses, tputs, ,
+ AC_CHECK_LIB(ncurses, tputs))))
AC_CHECK_LIB(readline, main)
if test $ac_cv_lib_readline_main = no; then
- AC_MSG_ERROR([vtysh needs libreadline but was not found on your system.])
+ AC_MSG_ERROR([vtysh needs libreadline but was not found and usable on your system.])
fi
AC_CHECK_HEADER(readline/history.h)
if test $ac_cv_header_readline_history_h = no;then
@@ -1106,8 +1114,10 @@ AC_OUTPUT(Makefile lib/Makefile zebra/Makefile ripd/Makefile
ripngd/Makefile bgpd/Makefile ospfd/Makefile
ospf6d/Makefile isisd/Makefile vtysh/Makefile doc/Makefile
ospfclient/Makefile
+ vtysh/extract.pl
redhat/Makefile redhat/quagga.spec
- lib/version.h)
+ lib/version.h,
+ [chmod +x vtysh/extract.pl])
echo "
zebra configuration