summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2004-11-07 19:39:13 +0000
committerpaul <paul>2004-11-07 19:39:13 +0000
commit6a22b1fc58e3690764bf7aa74d1549f26c315367 (patch)
tree3524a6a05340be54f0ad31fddb2df4119d696bec /doc/Makefile.am
parent0c3368a8da771423da4c59a9ccd65d9eb4f7af6a (diff)
2004-11-07 Paul Jakma <paul@dishone.st>
* Makefile.am: Add automatic rule to build pdf's from eps figures. Clean *.pdf. Add rule for quagga.pdf (as the eps.pdf pattern probably otherwise will override automake's rule for quagga.pdf) * overview.texi: URL was causing TeX overfull, put on newline. * quagga.texi: Put the copyright notice into @copying section, as is proper. Strip trailling space from the main menu lines. * rip(ng)?d.texi: Minor reformatting. * Add the route server docs. * bgpd.texi: remove unneeded page breaks. The 6Bone example overflows though.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am32
1 files changed, 30 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 916450f3..bcf55e24 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,13 +1,41 @@
## Process this file with automake to produce Makefile.in.
-info_TEXINFOS = quagga.texi
+EPSTOPDF = epstopdf
+
+# rather twisted logic because we have to build PDFs of the EPS figures
+# and yet build one PDF, quagga.pdf, from texi source. Which means we cant
+# rely on a single automatic rule for *.pdf.
+# If you are an automake wizard, please feel free to compact it somehow.
+#figures_pdfs = Normal-Announcement-processing.eps \
+# RS-Announcement-processing.eps \
+# topologias_full.eps topologias_rs.eps
+# Built from defines.texi.in
BUILT_SOURCES = defines.texi
+info_TEXINFOS = quagga.texi
+
+CLEANFILES = *.pdf
+
+# The figure sources
+figures_SOURCES = fig-normal-processing.eps \
+ fig_topologies_full.eps \
+ fig-rs-processing.eps \
+ fig_topologies_rs.eps
+
+# Have to manually
+quagga.pdf: quagga.texi \
+ fig-normal-processing.pdf fig_topologies_full.pdf \
+ fig-rs-processing.pdf fig_topologies_rs.pdf
+ $(TEXI2PDF) -o "$@" $(info_TEXINFOS)
+
quagga_TEXINFOS = appendix.texi basic.texi bgpd.texi filter.texi install.texi \
ipv6.texi kernel.texi main.texi ospf6d.texi ospfd.texi overview.texi \
protocol.texi ripd.texi ripngd.texi routemap.texi snmp.texi vtysh.texi \
- defines.texi
+ defines.texi $(figures_SOURCES)
+
+%.pdf: %.eps
+ $(EPSTOPDF) --outfile="$@" $<
man_MANS = vtysh.1 bgpd.8 ospf6d.8 ospfd.8 ripd.8 ripngd.8 zebra.8