summaryrefslogtreecommitdiff
path: root/isisd/Makefile.am
diff options
context:
space:
mode:
authorhasso <hasso>2005-04-02 19:03:39 +0000
committerhasso <hasso>2005-04-02 19:03:39 +0000
commitf695b01ff8e9aebc46bdf41f104ad4abbb0ef59e (patch)
tree1a36e624a6577780a49f6ae2c8e0534140d33943 /isisd/Makefile.am
parenta47d98f4b7d6e3c1f5298912672f7b4d55a203f0 (diff)
* configure.ac: Add --enable-isis-topology to enable isisd topology
generator code. * isisd/Makefile.am: Variables to handle conditonal compiling of topology generator code. * isisd/isis_lsp.c: lsppdu_realloc() is used by topology generator. * isisd/isisd.c: Rename show_isis_topology_cmd to not conflict the one in the isis_spf.c. * isisd/isisd.h: Remove TOPOLOGY_GENERATE define, it will be defined in toplevel config.h if topology generator is enabled. * isisd/topology/Makefile.am: Handle the libtoolized Quagga libraries.
Diffstat (limited to 'isisd/Makefile.am')
-rw-r--r--isisd/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/isisd/Makefile.am b/isisd/Makefile.am
index 7993643d..ceb948c5 100644
--- a/isisd/Makefile.am
+++ b/isisd/Makefile.am
@@ -1,12 +1,13 @@
## Process this file with automake to produce Makefile.in.
-# INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib -Itopology
-INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib
+INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib \
+ @ISIS_TOPOLOGY_INCLUDES@
DEFS = @DEFS@ -DSYSCONFDIR=\"$(sysconfdir)/\"
INSTALL_SDATA=@INSTALL@ -m 600
LIBS = @LIBS@
noinst_LIBRARIES = libisis.a
sbin_PROGRAMS = isisd
+SUBDIRS = @ISIS_TOPOLOGY_DIR@
libisis_a_SOURCES = \
isis_adjacency.c isis_lsp.c dict.c isis_circuit.c isis_pdu.c \
@@ -25,7 +26,7 @@ noinst_HEADERS = \
isisd_SOURCES = \
isis_main.c $(libisis_a_SOURCES)
-isisd_LDADD = ../lib/libzebra.la @LIBCAP@
+isisd_LDADD = @ISIS_TOPOLOGY_LIB@ ../lib/libzebra.la @LIBCAP@
examplesdir = $(exampledir)
dist_examples_DATA = isisd.conf.sample