summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorgdt <gdt>2004-06-30 17:36:11 +0000
committergdt <gdt>2004-06-30 17:36:11 +0000
commit87efd646ffef693235d9d29b005a1467373c51bd (patch)
tree85d43e323abb1de6b1ddb6e889f9d580fdb8546d /lib/Makefile.am
parentf2bfdee5f9db5363fcd13763eca3fda729067d57 (diff)
Add libtool support.
libzebra and libospfapiclient are now built shared, and linked shared with the daemons. This reduces the memory needed when running multiple daemons; each daemon is at least 150k smaller. Static libraries are still built, and libtool should use them on platforms which don't have shared libaries. As with autoconf, the user of a distribution does not need libtool; one just needs that to build from CVS. libospf.a is still a non-shared library, and still installed, not because that makese sense, but because I don't understand why it is the way it is now. Note that the tree was tagged 'libtool-before' just before this commit.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 45d60ced..eef9570f 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -3,9 +3,9 @@
INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib
DEFS = @DEFS@ -DSYSCONFDIR=\"$(sysconfdir)/\"
-lib_LIBRARIES = libzebra.a
+lib_LTLIBRARIES = libzebra.la
-libzebra_a_SOURCES = \
+libzebra_la_SOURCES = \
version.c network.c pid_output.c getopt.c getopt1.c daemon.c \
print_version.c checksum.c vector.c linklist.c vty.c command.c \
sockunion.c prefix.c thread.c if.c memory.c buffer.c table.c hash.c \
@@ -13,9 +13,9 @@ libzebra_a_SOURCES = \
zclient.c sockopt.c smux.c md5.c if_rmap.c keychain.c privs.c \
debug.c sigevent.c pqueue.c
-libzebra_a_DEPENDENCIES = @LIB_REGEX@
+libzebra_la_DEPENDENCIES = @LIB_REGEX@
-libzebra_a_LIBADD = @LIB_REGEX@
+libzebra_la_LIBADD = @LIB_REGEX@
pkginclude_HEADERS = \
buffer.h command.h filter.h getopt.h hash.h if.h linklist.h log.h \