summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2004-07-09 14:05:47 +0000
committerpaul <paul>2004-07-09 14:05:47 +0000
commitb9790b34c825e390c818044f6666f73beee1d373 (patch)
tree83d326652663957d7573a7ace0618b763289eacc /lib/Makefile.am
parent5510e83b395ccf19c07a89fee1baba958e3a580d (diff)
2004-07-09 Paul Jakma <paul@dishone.st>
* jhash.{c,h}: New files. Bob Jenkins' public domain hashing function, as implemented in linux kernel by David Miller.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index eef9570f..f49566d4 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -11,7 +11,7 @@ libzebra_la_SOURCES = \
sockunion.c prefix.c thread.c if.c memory.c buffer.c table.c hash.c \
filter.c routemap.c distribute.c stream.c str.c log.c plist.c \
zclient.c sockopt.c smux.c md5.c if_rmap.c keychain.c privs.c \
- debug.c sigevent.c pqueue.c
+ debug.c sigevent.c pqueue.c jhash.c
libzebra_la_DEPENDENCIES = @LIB_REGEX@
@@ -22,7 +22,7 @@ pkginclude_HEADERS = \
memory.h network.h prefix.h routemap.h distribute.h sockunion.h \
str.h stream.h table.h thread.h vector.h version.h vty.h zebra.h \
plist.h zclient.h sockopt.h smux.h md5-gnu.h if_rmap.h keychain.h \
- privs.h debug.h sigevent.h pqueue.h
+ privs.h debug.h sigevent.h pqueue.h jhash.h
EXTRA_DIST = regex.c regex-gnu.h